Publicado por: Rafael Guedes | 23 maio 2013

Enhanced vPC – O que é e como configurar?

COMO CONFIGURAR UMA TOPOLOGIA DE ENHANCED vPC

 

O que é Enhanced vPC?

Enhanced vPC nada mais é do que a utilização de vPC com os Cisco Nexus 5000, juntamente com a aplicação de FEXes em multihomed topology, ou seja, ou dois FEXes ligam aos dois Nexus 5000.

Na topologia Enhanced vPC os FEXes são line cards virtuais e as portas frontais dos FEXes são mapeadas para portas virtuais nos Nexus 5000 de uplink. Da perspectiva de CLI, a configuração de Enhanced vPC é o mesmo que a configuração de portchannels convencionais, com member ports nos dois FEXes. Um detalhe bastante importante neste caso, é que você não precisa entrar com a configuração “#vpc vpc_ID” para criar um Enhanced vPC.

A topologia é como a imagem abaixo:

Enhanced vPC

Embora o comando  “#vpc vpc_ID” não seja necessário, o NX-OS atribui automaticamente um vPC ID para cada Enhanced vPC. Mesmo assim, a saída do comando “#show vpc” mostra este vPC ID “interno.

Configuração passo a passo:

Passo 1 – Habilitar o vPC e o LACP

N5k-1(config)# feature vpc

N5k-1(config)# feature lacp

N5k-2(config)# feature vpc

N5k-2(config)# feature lacp

 

Passo 2 – Criar as VLANs

N5k-1(config)# vlan 10-20

N5k-2(config)# vlan 10-20

 

Passo  3 – Configuração básica do vPC

N5k-1(config)# vpc domain 100

N5k-1(config-vpc)# peer-keepalive destination 10.10.10.2

N5k-2(config)# vpc domain 100

N5k-2(config-vpc)# peer-keepalive destination 10.10.10.1

 

Passo 4 – Configuração do vPC peer-link

N5k-1(config)# interface eth1/1-2
N5k-1(config-if)# channel-group 1 mode active
N5k-1(config-if)# interface Po1
N5k-1(config-if)# switchport mode trunk
N5k-1(config-if)# switchport trunk allowed vlan 1, 10-20
N5k-1(config-if)# vpc peer-link

N5k-2(config)# interface eth1/1-2
N5k-2(config-if)# channel-group 1 mode active
N5k-2(config-if)# interface Po1
N5k-2(config-if)# switchport mode trunk
N5k-2(config-if)# switchport trunk allowed vlan 1, 10-20
N5k-2(config-if)# vpc peer-link

 

Passo 5 – Configuração do FEX 101

N5k-1(config)# fex 101

N5k-1(config-fex)# interface eth1/3-4

N5k-1(config-if)# channel-group 101 (sem LACP)

N5k-1(config-if)# interface po101

N5k-1(config-if)# switchport mode fex-fabric

N5k-1(config-if)# vpc 101

N5k-1(config-if)# fex associate 101

N5k-2(config)# fex 101

N5k-2(config-fex)# interface eth1/3-4

N5k-2(config-if)# channel-group 101 (sem LACP)

N5k-2(config-if)# interface po101

N5k-2(config-if)# switchport mode fex-fabric

N5k-2(config-if)# vpc 101

N5k-2(config-if)# fex associate 101

 

Passo 6 – Configuração do FEX 102

N5k-1(config)# fex 102

N5k-1(config-fex)# interface eth1/5-6

N5k-1(config-if)# channel-group 102 (sem LACP)

N5k-1(config-if)# interface po102

N5k-1(config-if)# switchport mode fex-fabric

N5k-1(config-if)# vpc 102

N5k-1(config-if)# fex associate 102

N5k-2(config)# fex 102

N5k-2(config-fex)# interface eth1/5-6

N5k-1(config-if)# channel-group 102 (sem LACP)

N5k-2(config-if)# interface po102

N5k-2(config-if)# switchport mode fex-fabric

N5k-2(config-if)# vpc 102

N5k-2(config-if)# fex associate 102

 

Passo 7 – Criação do Enhanced vPC

N5k-1(config)# interface eth101/1/1, eth101/1/2

N5k-1(config-if)# channel-group 2 mode active

N5k-1(config-if)# interface eth102/1/1, eth102/1/2

N5k-1(config-if)# channel-group 2 mode active

N5k-1(config-if)# int po2

N5k-1(config-if)# switchport access vlan 10

N5k-2(config)# interface eth101/1/1, eth101/1/2

N5k-2(config-if)# channel-group 2 mode active

N5k-2(config-if)# interface eth102/1/1, eth102/1/2

N5k-2(config-if)# channel-group 2 mode active

N5k-2(config-if)# int po2

N5k-2(config-if)# switchport access vlan 10

 

Como pôde ser visto no procedimento acima,  a configuração de um Enhanced vPC é a mesma de quando se configura um host portchannel com membros do mesmo FEX.

 

Publicado por: Rafael Guedes | 22 abril 2013

Tecnologia contra golpes – Aventuras de IKE

IKE contra ataca! =D

Estou escrevendo este artigo para auxiliar àquelas pessoas que possuem o arquivo de auto-configuração de VPN, mas que precisam configurar uma profile de VPN-IPSec em algum VPN Client que não possui a opção de importar um arquivo de auto-configuração.

Os arquivos de auto-configuração servem para facilitar a vida dos usuários finais que usam a VPN, e até mesmo para o mais experts em segurança, pois basta importar o arquivo no seu VPN Client de preferência, o que torna bastante prática e fácil a configuração.

Conheço dois formatos de arquivo de auto-configuração de VPN: o .pcf e o .vpn. O formato .pcf é exportado com base em um perfil de VPN-IPSec através do VPN client Cisco. Já o formato .vpn é exportado com base em um perfil de VPN-IPSec através do VPN Client Shrew.

Se você abrir o seu arquivo de auto-configuração .vpn ou .pcf, perceberá que nele estão contidas todas as informações necessárias para configuração o seu VPN client “na unha”. O grande problema é que o ‘Group Password’ está encriptado, e neste caso você não irá conseguir concluir a sua configuração, pois estará desprovido desta informação.

É justamente neste ponto que está a dica que gostaria de passar neste artigo. Existem formas de desencriptar estas senhas através de sites on-line, basta colar a string e processá-la no site, que ele retornará com a senha “legível” para que você consiga inserir no seu VPN Client, no meu caso usei para configurar a VPN no Ipad. =)

Seguem abaixo os sites capazes de realizar esta conversão:

Para .pcf – Cisco:

Para .vpn – Shrew:

Publicado por: Rafael Guedes | 1 fevereiro 2013

Sessão SSH bloqueada no NetApp

Ao tentar conectar via SSH na Service Processor de um NetApp FAS2240-2 (Data ONTAP NetApp Release 8.1.1 7-Mode), eu estava recebendo a seguinte mensagem:

host:~ user$ ssh -l naroot filer
ssh_exchange_identification: Connection closed by remote host

Tentei várias vezes, porém sempre a mesma mensagem. Pesquisei um pouco e encontrei um workarround para este problema. Seguem abaixo os passos executados:

  1. Simplesmente configure a sessão de SSH para executar um comando remoto. No meu caso eu simplesmente executei ‘version’.
  2. Conecte-se ao filer, irá solicitar usuário e senha. Preencha com suas credenciais de acesso e o comando remoto será executado e a saída do comando aparecerá em sua tela.
  3. Remova agora o comando da sessão de SSH.
  4. Conecte-se novamente no filer e agora deve funcionar!

Não encontrei a real causa disso. Mas enfim, para mim funcionou! Só tive que tentar algumas vezes.

Publicado por: Rafael Guedes | 22 janeiro 2013

VMware SRM + Storage vMotion e/ou Storage DRS

Para os colegas que, assim como eu, pensaram ou estão pensando em implementar o VMware Site Recovery Manager em conjunto com as funcionalidades de Storage vMotion e/ou Storage DRS, informo que isto não é possível. Este gap está exposto no release notes da versão 5.1 do SRM:

Interoperability with Storage vMotion and Storage DRS
Due to some specific and limited cases where recoverability can be compromised during storage movement, Site Recovery Manager 5.1 is not supported for use with Storage vMotion (SVmotion) and is not supported for use with the Storage Distributed Resource Scheduler (SDRS) including the use of datastore clusters.

Este item está sendo visto desde setembro de 2011 pela VMware como uma questão de alta prioridade, mas até então não houve uma resolução.

Ah, antes que eu me esqueça.. =) Nem mesmo utilizando o recurso de vSphere Replication é possível utilizar Storage vMotion e/ou Storage DRS.

Fontes:

http://blogs.vmware.com/vsphere/2011/09/storage-vmotion-storage-drs-site-recovery-manager-interoperability.html
http://www.vmware.com/support/srm/srm-releasenotes-5-1-0.html#caveats

Older Posts »

Categorias

Seguir

Obtenha todo post novo entregue na sua caixa de entrada.